
 
 

Task Coach – FAQ 
For use with Windows operating systems 

The following are some frequently asked questions about using Task Coach and a list of useful 
tips. See the User Manual for detailed instructions on using Task Coach. There is also a Quick 
Reference Card to use as a reminder tool.  
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 What is Task Coach?  
 Where can I download Task Coach? 
 What operating systems is Task Coach compatible with? 
 How do I install Task Coach?  
 What languages can I use Task Coach with? 
 Where can I get more information about Task Coach? 
 What if my problem isn’t here? Where can I get support? 
 


 

 What is Task Coach?  
Task Coach is a simple task manager that allows for parent and child 
tasks, i.e. a hierarchy of tasks. Task Coach is open source software 
(GPLv3+) and is developed using Python and wxPython 
 


 

 Where can I download Task Coach? 
You can download Task Coach from the Web site: 
http://www.taskcoach.org/.  
 



 

 What operating systems is Task Coach compatible with? 
Task Coach is available for Windows XP/Vista, Mac OS X, and Linux 
(Debian and RPM format). The questions in this FAQ only apply to 
Task Coach using the Window operating systems.  
 



 

 How do I install Task Coach? 
See the Task Coach Installation Guide. 
 



 

 What languages can I use Task Coach with?  
Task Coach is available in 33 languages. Select Edit > Preferences 
> Language to see whether your language is one of them. If your 
language is not available or the translation needs improvement, 
please consider helping with the translation of Task Coach. Visit 
http://www.taskcoach.org/  for more information about how you can 
help. 
 
The currently available languages are: Brazilian Portuguese, 
Bulgarian, Chinese (Simplified and Traditional), Czech, Danish, 
Dutch, English, Finnish, French, Galician, German, Greek, Hebrew, 
Hungarian, Italian, Japanese, Korean, Latvian, Norwegian, Persian, 
Polish, Portuguese, Romanian, Russian, Slovak, Spanish, Swedish, 
Thai, Turkish, Ukrainian 
 



 

 Where can I get more information about Task Coach? 
There are several sources for more information. 
1. You can join the  discussion group: 

http://tech.groups.yahoo.com/group/taskcoach/messages 


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http://patbarry.net/QRC_062509_PBarry.pdf
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http://tech.groups.yahoo.com/group/taskcoach/messages


2. Visit the Wiki where you can find architecture and  source code 
overviews: http://taskcoach.wiki.sourceforge.net/source-code-
overview 

3. You can visit the developer’s blog - 
http://taskcoach.blogspot.com/  

 
 What if my problem isn’t here? Where can I get support? 

There are several options for support: 
1. Request support at: 

http://sourceforge.net/tracker/?group_id=130831&atid=719135  
2. Task Coach has a mailing list where you can discuss usage of 

Task Coach with fellow users, discuss and request features and 
complain about bugs. Go to http://www.taskcoach.org/  and join 
today! 

3. You can browse the list of known bugs and submit a bug report 
yourself at: 
https://sourceforge.net/tracker/?func=add&group_id=130831&ati
d=719134.  

4. You can browse previously submitted feature requests: 
https://sourceforge.net/tracker/?group_id=130831&atid=719137 
and submit a feature request of your own: 
https://sourceforge.net/tracker/?func=add&group_id=130831&ati
d=719137.  

 



 

 GETTING STARTED  
 

 How do I create a task?  
 What information can Task Coach keep about my tasks? 
 How do I hide completed tasks? 
 Can I hide all subtasks?  
 Does Task Coach have any keyboard shortcuts? 
 How can I print my tasks and just what gets printed? 
 



 

 How do I create a task?  
There are actually two ways to do this. 
1. Click on Task in the menu and select New Task. 
2. Click on the New Task icon above the task window. 

 



 

 What information can Task Coach keep about my tasks? 
Task Coach keeps the following information for each task: 
 Subject: a single line that summarizes the task.  
 Description: a multi-line description of the task.  
 Due date: the date the task should be finished. This can be 

'None' indicating that this task has no fixed due date.  
 Start date: the first date on which the task can be started. The 

start date defaults to the date the task is created. It can also be 
'None' indicating that you don't really want to start this task. This 
can be convenient for e.g. registering sick leave.  

 Completion date: this date is 'None' as long as the task has not 
been completed. It is set to the current date when you mark the 
task as completed. The completion date can also be entered 
manually.  

 Budget: amount of hours available for the task.  


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 Hourly fee: the amount of money earned with the task per hour.  
 Fixed fee: the amount of money earned with the task regardless 

of the time spent.  
 
The following properties are calculated based on input values for due 
dates and budgets:  
 Days left: the number of days left until the due date.  
 Total budget: The sum of the task budget and the subtask 

budgets.  
 Time spent: effort spent on the task.  
 Total time spent: effort spent on the task and all subtasks, 

recursively.  
 Budget left: task budget minus time spent on the task.  
 Total budget left: total task budget minus total time spent.  
 Total fixed fee: The sum of the task’s fixed fee and the fixed fees 

of all subtasks.  
 Revenue: hourly fee times hours spent plus fixed fee.  
 Total revenue: sum of task revenue and revenue of all subtasks. 

 
Tasks always have exactly one of the following states:  
 Active: the start date is in the past and the due date in the future; 
 Inactive: the start date is in the future, or  
 Completed: the task has been completed.  

 
In addition, tasks can be referenced as:  
 Overdue: the due date is in the past;  
 Due today: the due date is today;  
 Over budget: no budget left;  
 Under budget: still budget left;  
 No budget: the task has no budget.  

 
The text of tasks is colored according to the following rules, 
assuming you haven’t changed the text colors through the 
preferences dialog:  
 Over due tasks are red;  
 Tasks due today are orange;  
 Active tasks are black text with a blue icon;  
 Future tasks are gray, and  
 Completed tasks are green.  

 
The background color of tasks is determined by the categories the 
task belongs to; see the section about category properties.  
 

 How do I hide all completed tasks? 
On the View menu, select Filter, then the Hide tasks that are 
option.  Select the kind of task you wish to hide. 
 



 

 Can I hide all subtasks? 
Yes. Press Ctrl + Shift + C to collapse all subtasks.  Press  
Ctrl + Shift + E to expand them all again. 
 



 



 Does Task Coach have any keyboard shortcuts? 
Yes. See the tables below that include many standard Windows 
shortcuts as well as those specific to Task Coach. 



 

  
Shortcut  Description Shortcut  Description 
Ctrl + C Copy Ctrl + Shift + C Collapse All Items
Ctrl + P Print Ctrl + Shift + P Page Setup 
Ctrl + S Save Ctrl + Shift + S Save As 
Ctrl + V Paste Ctrl + Shift + V Paste into Task 
Ctrl + X Cut   
Ctrl + Z Undo Ctrl + Shift + E Expand All Items 
Ctrl + O Open Ctrl + Shift + H Help 
Ctrl + W Close   
Ctrl + Q Quit Ctrl + Y Redo 
Ctrl + A Select All   
Ctrl + I Increase Priority Ctrl + Shift + I Maximize Priority 
Ctrl + D Decrease Priority Ctrl + Shift + D Minimize Priority 
Ctrl + Ins New Task Ctrl + Shift + Ins New Subtask 
Ctrl + PgDn Activate Next 

Viewer 
  

Ctrl + PgUp Activate Prev. 
Viewer 

  

Ctrl + Enter Mark Task 
Complete 

  

Ctrl + Del Delete Task    
   
 How can I print my tasks and just what gets printed? 

You can print whatever appears in the current viewer window using 
File > Print. If the current view shows the task list, the list of tasks 
will be printed. If the current viewer shows efforts grouped by month, 
then that’s what will be printed. Whatever columns appear in the 
current viewer and whatever filters are being applied will be reflected 
in what is printed. 
 



 

   
 CATEGORIES  
 

 Can I assign categories to my tasks and group them into 
hierarchies? 

 Can I filter the tasks so I see only the tasks I want to at a given 
time? 

 Can I color-code my tasks?  
 



 

 Can I assign categories to my tasks and group them into 
hierarchies?  
Tasks can belong to one or more categories. You first need to create 
the category using the Category menu (Category > New 
Category). Then, you can add a task to one or more defined 
categories when you create or edit it by clicking Category at the top 
of the New Task or Edit Task window and selecting the desired 
categories from among those listed. 
 



 



 Can I filter the tasks to see only the tasks I want to? 
You can limit the tasks shown in the task viewer to one or more 
categories by checking a category in the Category viewer. For 
example, if you have a category 'phone calls' and you select that 
category, then the task viewer will only show tasks belonging to that 
category. 
 



 

 Can I color-code my tasks? 
Categories can be assigned a color. Tasks in that category will be 
highlighted with that color. If a category has no color of its own, but it 
has a parent category with a color, the parent's color will be used. If 
a task belongs to multiple categories that each have a different color 
associated with them, a mixture of the colors will be used to highlight 
that task. 
 



 

   
 WORK EFFORT  
 

 Can I track the amount of time I spend on tasks?  
 What information can I capture about my work effort? 
 Is there a way to see the sum of time spent in all tasks? 
 Is there a way to calculate costs for each task?   
 



 

 Can I track the amount of time I spend on tasks? 
You can record the amount of time spent on a task by tracking Effort. 
Select a task and invoke Start tracking effort in the Effort menu or 
the context menu or via the Start tracking effort toolbar button. 
 



 

 What information can I capture about my work effort? 
Effort records have the following properties you can change:  
 Task: the task the effort belongs to.  
 Start date/time: start date and time of the effort.  
 Stop date/time: stop date and time of the effort. This can be 

'None' as long as you are still working on the task.  
 Description: a multi-line description of the effort.  
 The following properties are calculated from the properties 

above:  
o Time spent: how much time you have spent working on the 

task.  
o Total time spent: sum of time spent on the task and all 

subtasks, recursively.  
o Revenue: money earned with the time spent.  
o Total revenue: money earned with the total time spent. 

 



 

 Is there a way to see the sum of time spent in all tasks? 
It is possible to see this information by day, week, or month. Open 
an Effort viewer window and in the box above the column headers, 
click the arrow for the Effort Details drop-down menu. Select day, 
week, or month. 
 
It isn’t possible right now to see all time ever spent on all task. There 
is an open feature request for this already. A possible work-around is 
to make Task 1 and Task 2 subtasks of another task and turn on the 



 



total time spent column in the effort viewer. 
 

 Is there a way to calculate costs for each task?  
Yes. In the New Task and Edit Task windows, you can enter both a 
fixed fee and an hourly fee for each task and a budgeted number of 
hours.  Use the Effort Tracker to track the hours you spend on the 
task and Task Coach will calculate the cost as hours worked times 
the hourly rate plus the fixed fee. 
 



 

   
 EMAIL INTEGRATION  
 

 Does Task Coach integrate with mail user agents?  
 How doe the e-mail integration work? 
 Can I attach an e-mail to a task? 
 Can I create a task from an e-mail?  
 



 

 Does Task Coach integrate with mail user agents? 
Yes, Task Coach integrates with both the Outlook and Thunderbird 
mail user agents. 
 



 

 How doe the e-mail integration work? 
Task Coach integrates with both Outlook and Thunderbird mail user 
agents, through drag and drop.  
 
This approach has some limitations, however. Emails are copied in a 
directory next to the Task Coach file, as .eml files, and are later 
opened using whatever program is associated with this file type on 
your system. On the other hand, this allows you to open these e-mail 
attachments on a system which is different from the one you created 
it in first.  
 
Using Outlook, you can drag and drop several e-mails at a time. Due 
to a Thunderbird limitation, you can only drag and drop one e-mail at 
a time from Thunderbird.  
 



 

 Can I attach an e-mail to a task? 
Yes. There are two ways to attach an e-mail to a task; you can:  
 Drop it onto a task either in the task tree or the task list. Or 
 Drop it into the attachment pane in the task editor.  

 



 

 Can I create a task from an e-mail? 
Yes. Dragging an e-mail onto an empty part of the task tree or task 
list creates a new task. The task subject and description will be equal 
to the email subject and content. The original email will also be 
automatically attached to the newly created task.  
 



 

  
 

 

 PREFERENCES  
 

 What options do I have for setting up Task Coach?  
 Where do I set what language I want Task Coach to use? 



 



 How do I set up SyncML? 
 What are the possible synchronization modes?  
 

 What options do I have for setting up Task Coach?  
You can set several options for how Task Coach works. Click Edit > 
Preferences. The options are grouped into the following categories: 
 
Window Behavior 
 You can set the options [Y/N] on this screen to show the splash 

screen and/or tips on startup. 
 Start with main window iconized [Y/N/Last].  

If iconized, the main screen doesn’t appear. Click on the Task 
Coach icon in the Windows task bar to restore it. 

 Show popup descriptions when hovering [Y/N].  
Selecting this option means that Note contents and 
attachment indicators will appear when your cursor hovers 
over the task in the Task viewer window. 

 
Task Behavior 
You can set the option to have Task Coach mark parent tasks 
complete when all child tasks are complete [Y/N]. This is a global 
setting but can be over-ridden for individual tasks. See the Quick 
Reference Card. 
 
Language 
You can select the language you want to use. See the next question 
for more information. 
 
Color 
You can set the text colors Task Coach uses for active, inactive, 
completed, over due, due today. 
 
Features   
You can turn the following features on or off: Tracking Effort, Writing 
    notes, Enabling SyncML. 
You can tell Task Coach what hours to start & end the day. 
 



 

 Where do I set what language I want Task Coach to use? 
Click Edit > Preferences. In the Preferences window, click 
Language. 
Select the language you want from the drop-down list. You must 
restart Task Coach before your selection takes effect. If the 
language you want isn’t available, please see:  
http://www.taskcoach.com/i18n.html. 
 



 

 How do I set up SyncML?  
Select Edit > SyncML Preferences. 
Access -  Input the SyncML Server URL and your User Name/ID 
Tasks – Enable task synchronization, enter task database name, 

and select   preferred synchronization mode. 
Notes - Enable notes synchronization, enter notes database name, 

and select   preferred synchronization mode. 
 


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 What are the possible synchronization modes?  
 2-way – Retains all tasks/notes in both Outlook and Task Coach. 
 1-way from client – Synchronizes Outlook and Task coach, 

retaining only Task Coach tasks in Outlook.  
 1-way from server - Synchronizes Outlook and Task coach, 

retaining only Outlook tasks in Task Coach. 
 Refresh from client – Uploads Task Coach files to Outlook 

without deleting Outlook tasks that don’t exist in Task Coach. 
 Refresh from server - Downloads Outlook files to Task Coach 

without deleting Task Coach tasks that don’t exist in Outlook. 
 



 

  
 

 

 SYNC ML  
 

 What is SyncML?   
 How do I set up SyncML? 
 What are the possible synchronization modes? 
 Are there any cautions to using SyncML?  
 I’m having trouble getting this to work. What could be wrong? 
 



 

 What is SyncML?  
SyncML is a feature that lets you synchronize your Outlook and Task 
Coach tasks and notes using a server such as Funambol. 
 
SyncML is an XML protocol designed to synchronize several 
applications with a server. A popular open-source server is 
Funambol. Synchronization clients are available for many devices 
and applications (Outlook, Pocket PC, iPod, iPhone, Evolution, 
etc...), as well as so-called "connectors" which allow the server to 
synchronize with Exchange, Google Calendar, etc.  
 
Task Coach has built-in SyncML client support. This means you can 
setup Task Coach to synchronize with the same SyncML server you 
synchronize with Outlook and have all Outlook tasks and notes in 
your Task Coach file, as well as Task Coach tasks and notes in 
Outlook.  
 



 

 How do I set up SyncML? 
Select Edit > SyncML Preferences. 
Access -  Input the SyncML Server URL and your ID on the server 
     The URL depends on the server you choose. Some examples: 
      ScheduleWorld: http://sync.scheduleworld.com/funambol/ds   
      MemoToo: http://sync.memotoo.com/syncml   
Tasks/Notes – Enable tasks/notes synchronization, enter task/notes 

database name, and select preferred synchronization mode. 
Note:   Each task file has its own client ID, so that two different task 

files will be considered different "devices" by the server. 
 



 

 What are the possible synchronization modes? 
 2-way – Retains all tasks/notes in both Outlook and Task Coach. 
 1-way from client – Synchronizes Outlook and Task coach, 

retaining only Task Coach tasks in Outlook.  


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 1-way from server - Synchronizes Outlook and Task coach, 
retaining only Outlook tasks in Task Coach. 

 Refresh from client – Uploads Task Coach files to Outlook 
without deleting Outlook tasks that don’t exist in Task Coach. 

 Refresh from server - Downloads Outlook files to Task Coach 
without deleting Task Coach tasks that don’t exist in Outlook. 

 
 Are there any cautions to using SyncML? 

Yes there are. Because the underlying data type is vCalendar, some 
Task Coach features cannot be presented to the server.  
 Task and category hierarchy are lost to the server.  
 Recurrence and reminders are not supported yet.  
 Note categories are lost to the server.  

 
The conflict detection/resolution system is a work around for a 
Funambol limitation. It should work in most cases, but if many 
applications synchronize with the same server at the same time, 
problems may rise.  
 



 

 I’m having trouble getting this to work. What could be wrong? 
The SyncML menu items are only present if you are using the 
Windows, 32 bits platform. You may experience problems under 
Windows if you don't have the Microsoft Visual 8 runtime installed. 
You can download it on the Microsoft download site.    
 



 

   
 TIPS  
 If you enter a Web site address (e.g. http://www.taskcoach.org/) in 

the description for a task, category, or note, clicking on the link will 
open the URL in your default web browser. 
 



 

 You can drag and drop tasks in the tree view to rearrange parent-
child relationships between tasks. The same action applies for 
categories. 
 



 

 You can drag files from a file browser onto a task to create 
attachments. Dragging the files over a viewer window header will 
raise the appropriate page, dragging the files over the plus sign [+] 
next to a parent task in the tree view will expand the task to show its 
subtasks. 
 



 

 You can create any viewer layout you want by dragging and 
dropping the viewer windows. Due to a limitation of the current 
version of the graphical toolkit (wxPython), the layout cannot be 
saved for reuse in the next session. 
 



 

 Task Coach has unlimited undo and redo. Any change you make, be 
it editing a task description, or deleting an effort record, is undoable. 
Select Edit > Undo or Edit > Redo to go backward and forward 
through your edit history. 
 



 

 
 


